Beginilah kalo nulis artikel asal2an, jadi ngga urutan. Dari cara bikin NAT ma proxy trus mundur ke cara install mikrotik, sekarang tinggal cara dial ke internet menggunakan speedy. Tapi ngga pa2lah yang penting posting aj. Topologinya kurang lebih seperti ini :

Internet lewat jalur telpon 0.0.0.0—->modem —>router—>switch—>client

0.0.0.0 ->192.168.1.1->192.168.1.2//192.168.0.1->192.168.0.2-192.168.0.254

Pertama2 silahkan setting modemnya dengan mode bridge kasih ip 192.168.1.1 , Sudah bisalah, terus lanjut install mikrotik, dah bisa juga, lanjut kasih ip di dua interface yang terpasang di mikrotik , satu interface tuk koneksi ke modem diberi IP 192.168.1.2. Satu lagi untuk koneksi ke LAN dikasih IP 192.168.0.1. Caranya :

interface ethernet set ether1 name=Speedy
interface ethernet set ether2 name=Local

ip address add address=192.168.1.2/24 interface=Speedy
ip address add address=192.168.0.1/24 interface=Local

Tahapan selanjutnya adalah mengaktifkan fitur PPOE pada Modem ADSL Speedy lewat Mikrotik.

/interface pppoe-client add name=pppoe-user-speedy user=111xxxxxxxxx@telkom.net password=(masukkan pasword speedy) interface=Speedy service-name=internet disabled=no

/ip route add gateway= 125.163.244.1(dapat diketahui dengan command ipconfig pada saat dial speedy via windows)
/ip route print

Setting DNS

/ip dns set primary-dns=202.134.0.61 allow-remote-request=yes
/ip dns set secondary-dns=202.134.0.155 allow-remote-request=yes

Selanjutnya proses masquerading, untuk penerusan perintah dari routing yang diteruskan ke nat firewall mikrotik untuk proses routing ke semua client yang terhubung.

/ip firewall nat add chain=srcnat action=masquerade

Langkah terakhir, buka winbox, pada menu pppoe pastikan ceklist pada “add default route”
Setelah Proses diatas selesai, lakukan ping ke 202.134.0.155 jika koneksi terhubung artinya Mikrotik telah mengaktifkan Speedy sebagai Gateway Internetnya.

Untuk hasi settinganya silahkan bisa dilihat lewat winbox dibagian PPP. Tampilanya kurang  lebih seperti ini :

Lihat settingan Interface, selain 2 etherne, ada juga pppoe yang menunjukan kita dial ke internet menggunakan pppoe di mikrotik.

pppoe

Setelah dial pppoe:

pppoe1

pppoe2

Setalah proces NAT:

NAT masquarede

Ket:  sampai tahap ini yang aktif cuman ada 1 baris aja yaitu baris ke 2. Baris lainya anggap aja ngga ada.